Click or drag to resize

MeshTextureCoordinateList Methods

The MeshTextureCoordinateList type exposes the following members.

Methods
  NameDescription
Public methodAdd(Point2f)
Adds a new texture coordinate to the end of the Texture list.
Public methodAdd(Point3d)
Adds a new texture coordinate to the end of the Texture list.
Public methodAdd(Double, Double)
Adds a new texture coordinate to the end of the Texture list.
Public methodAdd(Single, Single)
Adds a new texture coordinate to the end of the Texture list.
Public methodAddRange
Appends an array of texture coordinates.
Public methodClear
Clears the Texture Coordinate list on the mesh.
Public methodDestroy
Releases all memory allocated to store texture coordinates. The list capacity will be 0 after this call.

Subsequent calls can add new items.

Public methodGetEnumerator
Gets an enumerator that yields all texture coordinates in this collection.
Public methodNormalizeTextureCoordinates
Scales the texture coordinates so the texture domains are [0,1] and eliminate any texture rotations.
Public methodReverseTextureCoordinates
Reverses one coordinate direction of the texture coordinates.

The region of the bitmap the texture uses does not change. Either Us or Vs direction is flipped.

Public methodSetTextureCoordinate(Int32, Point2f)
Sets or adds a texture coordinate to the Texture Coordinate List.

If [index] is less than [Count], the existing coordinate at [index] will be modified.

If [index] equals [Count], a new coordinate is appended to the end of the coordinate list.

If [index] is larger than [Count], the function will return false.

Public methodSetTextureCoordinate(Int32, Point3f)
Sets or adds a texture coordinate to the Texture Coordinate List.

If [index] is less than [Count], the existing coordinate at [index] will be modified.

If [index] equals [Count], a new coordinate is appended to the end of the coordinate list.

If [index] is larger than [Count], the function will return false.

Public methodSetTextureCoordinate(Int32, Double, Double)
Sets or adds a texture coordinate to the Texture Coordinate List.

If [index] is less than [Count], the existing coordinate at [index] will be modified.

If [index] equals [Count], a new coordinate is appended to the end of the coordinate list.

If [index] is larger than [Count], the function will return false.

Public methodSetTextureCoordinate(Int32, Single, Single)
Sets or adds a texture coordinate to the Texture Coordinate List.

If [index] is less than [Count], the existing coordinate at [index] will be modified.

If [index] equals [Count], a new coordinate is appended to the end of the coordinate list.

If [index] is larger than [Count], the function will return false.

Public methodSetTextureCoordinates(Point2f)
Sets all texture coordinates in one go.
Public methodSetTextureCoordinates(TextureMapping)
Set all texture coordinates based on a texture mapping function
Public methodToFloatArray
Copies all vertices to a linear array of float in u,v order
Public methodTransposeTextureCoordinates
Transposes texture coordinates.

The region of the bitmap the texture uses does not change. All texture coordinates rows (Us) become columns (Vs), and vice versa.

Top
See Also