RhinoViewportSetViewProjection Method |
Sets the viewport camera projection.
Namespace:
Rhino.Display
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool SetViewProjection(
ViewportInfo projection,
bool updateTargetLocation
)
Public Function SetViewProjection (
projection As ViewportInfo,
updateTargetLocation As Boolean
) As Boolean
Parameters
- projection
- Type: Rhino.DocObjectsViewportInfo
The "standard" projection type. - updateTargetLocation
- Type: SystemBoolean
if true, the target location is changed so that the vector from the camera location to the target
is parallel to the camera direction vector. If false, the target location is not changed.
Return Value
Type:
Booleantrue on success.
See Also