Click or drag to resize

RhinoViewportGetFrustumLine Method

Gets the world coordinate line in the view frustum that projects to a point on the screen.

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool GetFrustumLine(
	double screenX,
	double screenY,
	out Line worldLine
)

Parameters

screenX
Type: SystemDouble
(screenx,screeny) = screen location.
screenY
Type: SystemDouble
(screenx,screeny) = screen location.
worldLine
Type: Rhino.GeometryLine
3d world coordinate line segment starting on the near clipping plane and ending on the far clipping plane.

Return Value

Type: Boolean
true if successful. false if view projection or frustum is invalid.
See Also