Click or drag to resize

RhinoViewportRotate Method

Rotates about the specified axis. A positive rotation angle results in a counter-clockwise rotation about the axis (right hand rule).

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool Rotate(
	double angleRadians,
	Vector3d rotationAxis,
	Point3d rotationCenter
)

Parameters

angleRadians
Type: SystemDouble
angle of rotation in radians.
rotationAxis
Type: Rhino.GeometryVector3d
direction of the axis of rotation.
rotationCenter
Type: Rhino.GeometryPoint3d
point on the axis of rotation.

Return Value

Type: Boolean
true if geometry successfully rotated.
See Also