Click or drag to resize

RhinoViewportSetProjection Method

Set viewport to a defined projection.

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool SetProjection(
	DefinedViewportProjection projection,
	string viewName,
	bool updateConstructionPlane
)

Parameters

projection
Type: Rhino.DisplayDefinedViewportProjection
The "standard" projection type.
viewName
Type: SystemString
If not null or empty, the name is set.
updateConstructionPlane
Type: SystemBoolean
If true, the construction plane is set to the viewport plane.

Return Value

Type: Boolean
true if successful.
See Also