Click or drag to resize

MeshFaceListGetFaceCenter Method

Gets the center point of a face.

For a triangular face, this is the centroid or barycenter.

For a quad, this is the average of four comer points.

Namespace:  Rhino.Geometry.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Point3d GetFaceCenter(
	int faceIndex
)

Parameters

faceIndex
Type: SystemInt32
A face index.

Return Value

Type: Point3d
The center point.
See Also