Click or drag to resize

MeshFaceListCullDegenerateFaces Method

Attempts to removes degenerate faces from the mesh.

Degenerate faces are faces that contains such a combination of indices, that their final shape collapsed in a line or point.

Before returning, this method also attempts to repair faces by juggling vertex indices.

Namespace:  Rhino.Geometry.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public int CullDegenerateFaces()

Return Value

Type: Int32
The number of degenerate faces that were removed.
See Also