RhinoCommon API
RhinoCommon API
Namespaces
Rhino.Geometry.Collections
MeshFaceList Class
MeshFaceList Methods
AddFace Method
AddFaces Method
AdjacentFaces Method
Clear Method
ConvertNonPlanarQuadsToTriangles Method
ConvertQuadsToTriangles Method
ConvertTrianglesToQuads Method
CullDegenerateFaces Method
DeleteFaces Method
Destroy Method
ExtractDuplicateFaces Method
ExtractFaces Method
GetClashingFacePairs Method
GetConnectedFaces Method
GetConnectedFacesToEdges Method
GetDuplicateFaces Method
GetEnumerator Method
GetFace Method
GetFaceAspectRatio Method
GetFaceBoundingBox Method
GetFaceCenter Method
GetFaceVertices Method
GetTopologicalVertices Method
GetZeroAreaFaces Method
HasNakedEdges Method
Insert Method
IsHidden Method
MergeAdjacentFaces Method
RemoveAt Method
RemoveZeroAreaFaces Method
SetFace Method
ToIntArray Method
MeshFaceList
Clear Method
Clears the Face list on the mesh.
Namespace:
Rhino.Geometry.Collections
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since:
5.0
Syntax
C#
VB
Copy
public
void
Clear
()
Public
Sub
Clear
Implements
ICollection
T
Clear
IList
Clear
See Also
Reference
MeshFaceList Class
Rhino.Geometry.Collections Namespace
Rhino 8.13.24317.13000 (2024-11-12)
Copyright © 2009-2024 Robert McNeel & Associates
Report wishes and bugs at discourse.mcneel.com