Click or drag to resize

MeshNgonList Class

Provides access to the ngons and ngon-related functionality of a Mesh. See also the Ngons property for Ngon functionality details.
Inheritance Hierarchy
SystemObject
  Rhino.Geometry.CollectionsMeshNgonList

Namespace:  Rhino.Geometry.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class MeshNgonList : IResizableList<MeshNgon>, 
	IList<MeshNgon>, ICollection<MeshNgon>, IEnumerable<MeshNgon>, 
	IEnumerable, IList, ICollection, IReadOnlyList<MeshNgon>, 
	IReadOnlyCollection<MeshNgon>

The MeshNgonList type exposes the following members.

Properties
  NameDescription
Public propertyCount
Gets or sets the number of mesh ngons.
Public propertyItem
Returns the mesh ngon at the given index.
Public propertyUnsignedCount
Gets or sets the number of mesh ngons.
Top
Methods
  NameDescription
Public methodAddNgon
Appends a new ngon to the end of the mesh ngon list.
Public methodAddNgons
Appends a list of ngons to the end of the mesh ngon list.
Public methodAddPlanarNgons(Double)
Add an ngon for each group of connected coplanar faces.
Public methodAddPlanarNgons(Double, Int32, Int32, Boolean)
Add an ngon for each group of connected coplanar faces.
Public methodClear
Clears the Ngon list on the mesh.
Public methodGetEnumerator
Gets an enumerator that yields all ngons in this collection.
Public methodGetNgon
Returns the mesh ngon at the given index.
Public methodGetNgonBoundary
Get a list of vertices that form the boundary of a face set. This is often use to get ngon boundaries.
Public methodGetNgonBoundingBox(Int32)
Gets the bounding box of an ngon.
Public methodGetNgonBoundingBox(MeshNgon)
Gets the bounding box of an ngon.
Public methodGetNgonCenter(Int32)
Gets the center point of an ngon.

This the average of the corner points.

Public methodGetNgonCenter(MeshNgon)
Gets the center point of an ngon.

This the average of the corner points.

Public methodGetNgonEdgeCount
Gets the complete edge count of an ngon.
Public methodGetNgonOuterEdgeCount
Gets the outer edge count of an ngon.
Public methodInsert
Inserts a mesh ngon at a defined index in this list.
Public methodIsValid(Int32)
Tests an ngon to see if the vertex and face references are valid and pass partial boundary validity checks.
Public methodIsValid(Int32, TextLog)
Tests an ngon to see if the vertex and face references are valid and pass partial boundary validity checks.
Public methodNgonBoundaryVertexList
Get an ngon's boundary points.
Public methodNgonHasHoles
Determines whether a ngon has holes.
Public methodNgonIndexFromFaceIndex
Returns the index of a mesh ngon the face belongs to.
Public methodOrientation
Determine if the ngon's boundary orientation matches that of the set of faces it is made from.
Public methodRemoveAt
Removes an ngon from the mesh.
Public methodRemoveNgons
Remove one or more ngons from the mesh.
Public methodReverseOuterBoundary
Reverse the order of the m_vi[] array for an ngon
Public methodSetNgon
Set an ngon in this list.
Top
See Also