Click or drag to resize

TrulyObservableOrderedSetT Class

An ordered set that notifies its subscribers whenever one of its INotifyPropertyChanged elements raises its PropertyChanged event.
Inheritance Hierarchy
SystemObject
  Rhino.Runtime.NotificationsTrulyObservableOrderedSetT

Namespace:  Rhino.Runtime.Notifications
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class TrulyObservableOrderedSet<T> : IList<T>, 
	ICollection<T>, IEnumerable<T>, IEnumerable, INotifyCollectionChanged
where T : INotifyPropertyChanged, IAssemblyRestrictedObject

Type Parameters

T
A class that implements INotifyPropertyChanged as well as IAssemblyRestrictedObject

The TrulyObservableOrderedSetT type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyCount
Returns the total number of items in the set.
Public propertyIsReadOnly
Always returns false.
Public propertyItem
Gets or replaces an element in the ordered set at the specified index.
Top
Methods
  NameDescription
Public methodAdd
Adds an object to the end of the ordered set if the set does not already contain the item.
Public methodClear
Clears the ordered set.
Public methodContains
Determines whether an element is in the set.
Public methodCopyTo
Copies the values of the set to an array.
Public methodGetEnumerator
Returns an enumerator that iterates through the set.
Public methodIndexOf
Searches for the specified object and returns the zero-based index of the first occurrence.
Public methodInsert
Inserts an element at the specified index.
Public methodRemove
Removes an element from the set.
Public methodRemoveAt
Removes an element at the specified index from the set.
Public methodSortTKey
Sorts the set.
Top
Events
  NameDescription
Public eventCollectionChanged
Triggered whenever the set changes or when one of its elements has its PropertyChanged event triggered.
Top
Remarks
This class prevents the removal of elements by assemblies they cannot be edited by. At the time of removal, each element's Editable method will be invoked, and if false, an InvalidOperationException will be thrown.
See Also