RhinoCommon API
RhinoCommon API
Namespaces
Rhino.Runtime.Notifications
TrulyObservableOrderedSet(T) Class
TrulyObservableOrderedSet(T) Methods
Add Method
Clear Method
Contains Method
CopyTo Method
GetEnumerator Method
IndexOf Method
Insert Method
Remove Method
RemoveAt Method
Sort(TKey) Method
TrulyObservableOrderedSet
T
Clear Method
Clears the ordered set.
Namespace:
Rhino.Runtime.Notifications
Assembly:
RhinoCommon (in RhinoCommon.dll)
Syntax
C#
VB
Copy
public
void
Clear
()
Public
Sub
Clear
Implements
ICollection
T
Clear
Exceptions
Exception
Condition
InvalidOperationException
Thrown if at least one item currently in the set cannot be modified by the current assembly.
See Also
Reference
TrulyObservableOrderedSet
T
Class
Rhino.Runtime.Notifications Namespace
Rhino 8.13.24317.13000 (2024-11-12)
Copyright © 2009-2024 Robert McNeel & Associates
Report wishes and bugs at discourse.mcneel.com