LayerTable Class |
[Missing <summary> documentation for "T:Rhino.DocObjects.Tables.LayerTable"]
Namespace: Rhino.DocObjects.Tables
The LayerTable type exposes the following members.
Name | Description | |
---|---|---|
ActiveCount |
Returns number of layers in the layer table, excluding deleted layers.
| |
ComponentType | (Overrides CommonComponentTableTComponentType.) | |
Count |
Returns number of layers in the layer table, including deleted layers.
(Overrides CommonComponentTableTCount.) | |
CurrentLayer |
At all times, there is a "current" layer. Unless otherwise specified,
new objects are assigned to the current layer. The current layer is
never locked, hidden, or deleted.
Returns reference to the current layer. Note that this reference may
become invalid after a call to AddLayer().
| |
CurrentLayerIndex |
At all times, there is a "current" layer. Unless otherwise specified, new objects
are assigned to the current layer. The current layer is never locked, hidden, or deleted.
Returns: Zero based layer table index of the current layer.
| |
Document | Document that owns this table. | |
Item |
Conceptually, the layer table is an array of layers.
The operator[] can be used to get individual layers. A layer is
either active or deleted and this state is reported by Layer.IsDeleted.
|
Name | Description | |
---|---|---|
Add |
Adds a new layer with default definition to the layer table.
| |
Add(Layer) |
Adds a new layer with specified definition to the layer table.
| |
Add(String, Color) |
Adds a new layer with specified definition to the layer table.
| |
AddPath(String) |
Adds all of the layer in the specified layer path, beginning with the root.
Layer paths contain one or more valid layers names, with each name separated by NamePathSeparator.
For example, "Grandfather::Father::Son".
| |
AddPath(String, Color) |
Adds all of the layer in the specified layer path, beginning with the root.
Layer paths contain one or more valid layers names, with each name separated by NamePathSeparator.
For example, "Grandfather::Father::Son".
| |
AddReferenceLayer |
Adds a new reference layer with default definition to the layer table.
Reference layers are not saved in files.
| |
AddReferenceLayer(Layer) |
Adds a new reference layer with specified definition to the layer table
Reference layers are not saved in files.
| |
Clear |
Marks all items as deleted.
(Inherited from CommonComponentTableT.) | |
CreateLayer |
Basic tool used by the add layer methods.
| |
Delete(Layer) | Deletes layer. (Overrides CommonComponentTableTDelete(T).) | |
Delete(Guid, Boolean) | Deletes layer. | |
Delete(IEnumerableInt32, Boolean) |
Deletes layers.
| |
Delete(Int32, Boolean) | Deletes layer. | |
Delete(Layer, Boolean) | Deletes layer. | |
Duplicate(IEnumerableInt32, Boolean, Boolean) |
Duplicates, or copies, one or more layers. Duplicated layers are added to the document.
| |
Duplicate(Int32, Boolean, Boolean) |
Duplicates, or copies, a layer. Duplicated layers are added to the document.
| |
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) | |
FindByFullPath |
Searches for a layer using the fully qualified name, that includes ancestors.
Deleted layers have no name. | |
FindId |
Uses the guid to find a model component. Deleted objects cannot be found by id.
The guid is the value that is stored in the .Id property.
In a single document, no two active objects have the same guid. If an object is
replaced with a new object, then the guid persists. For example, if the _Move command
moves an object, then the moved object inherits its guid from the starting object.
If the Copy command copies an object, then the copy gets a new guid. This guid persists
through file saving/opening operations. This function will not find grip objects.
(Inherited from CommonComponentTableT.) | |
FindIndex |
Retrieves a Layer object based on Index. This search type of search is discouraged.
We are moving towards using only IDs for all tables.
| |
FindName(String) |
Finds the layer with a given name. If multiple layers exist that have the same name, the
first match layer index will be returned.
Deleted layers have no name. The default layer is NOT included in the search. If required, use the overload with startIndex input. | |
FindName(String, Int32) |
Finds the next layer that has an index equal or higher than the searched value.
Search in case-insensitive. | |
FindNameHash |
Finds a Layer given its name hash.
| |
ForceLayerVisible(Guid) |
Makes a layer and all of its parent layers visible.
| |
ForceLayerVisible(Int32) |
Makes a layer and all of its parent layers visible.
| |
GetEnumerator | (Overrides CommonComponentTableTGetEnumerator.) | |
GetHashCode | Serves as the default hash function. (Inherited from Object.) | |
GetSelected |
Returns the indices of layers that are selected on the Layer user interface.
| |
GetSorted |
Gets an array of layer indices that are sorted by the values of SortIndex.
| |
GetType | Gets the Type of the current instance. (Inherited from Object.) | |
GetUnusedLayerName |
Gets the next unused layer name used as default when creating new layers.
| |
GetUnusedLayerName(Boolean) | Obsolete.
Gets the next unused layer name used as default when creating new layers.
| |
Modify(Layer, Guid, Boolean) | Modifies layer settings. | |
Modify(Layer, Int32, Boolean) | Modifies layer settings. | |
Purge(Guid, Boolean) |
Deletes a layer and all geometry objects on a layer.
| |
Purge(Int32, Boolean) |
Deletes a layer and all geometry objects on a layer
| |
Select |
Selects layers in the Layer user interface.
| |
SetCurrentLayerIndex |
At all times, there is a "current" layer. Unless otherwise specified, new objects
are assigned to the current layer. The current layer is never locked, hidden, or deleted.
| |
Sort |
Updates the layer sort order
| |
SortByLayerName |
Sort layers, in the layer table, by their name in either ascending or descending order.
This function sorts layers in the same manner as Rhino's Layers panel.
| |
ToString | Returns a string that represents the current object. (Inherited from Object.) | |
Undelete |
Undeletes a layer that has been deleted by DeleteLayer().
| |
UndoModify(Guid) |
Restores the layer to its previous state,
if the layer has been modified and the modification can be undone.
| |
UndoModify(Int32) |
Restores the layer to its previous state,
if the layer has been modified and the modification can be undone.
| |
UndoModify(Guid, UInt32) |
Restores the layer to its previous state,
if the layer has been modified and the modification can be undone.
| |
UndoModify(Int32, UInt32) |
Restores the layer to its previous state,
if the layer has been modified and the modification can be undone.
|