Click or drag to resize

LayerTable Properties

The LayerTable type exposes the following members.

Properties
  NameDescription
Public propertyActiveCount
Returns number of layers in the layer table, excluding deleted layers.
Public propertyComponentType (Overrides CommonComponentTableTComponentType.)
Public propertyCount
Returns number of layers in the layer table, including deleted layers.
(Overrides CommonComponentTableTCount.)
Public propertyCode exampleCurrentLayer
At all times, there is a "current" layer. Unless otherwise specified, new objects are assigned to the current layer. The current layer is never locked, hidden, or deleted. Returns reference to the current layer. Note that this reference may become invalid after a call to AddLayer().
Public propertyCode exampleCurrentLayerIndex
At all times, there is a "current" layer. Unless otherwise specified, new objects are assigned to the current layer. The current layer is never locked, hidden, or deleted. Returns: Zero based layer table index of the current layer.
Public propertyDocument
Document that owns this table.
Public propertyItem
Conceptually, the layer table is an array of layers. The operator[] can be used to get individual layers. A layer is either active or deleted and this state is reported by Layer.IsDeleted.
Top
See Also