Click or drag to resize

RTree Methods

The RTree type exposes the following members.

Methods
  NameDescription
Public methodClear
Removes all elements.
Public methodStatic memberCreateFromPointArray
Constructs a new tree with an element for each point cloud point.
Public methodStatic memberCreateMeshFaceTree
Constructs a new tree with an element for each face in the mesh. The element id is set to the index of the face.
Public methodStatic memberCreatePointCloudTree
Constructs a new tree with an element for each point cloud point.
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodInsert(BoundingBox, Int32)
Inserts an element into the tree.
Public methodInsert(BoundingBox, IntPtr)
Inserts an element into the tree.
Public methodInsert(Point2d, Int32)
Inserts an element into the tree.
Public methodInsert(Point2d, IntPtr)
Inserts an element into the tree.
Public methodCode exampleInsert(Point3d, Int32)
Inserts an element into the tree.
Public methodInsert(Point3d, IntPtr)
Inserts an element into the tree.
Public methodStatic memberPoint3dClosestPoints
Finds the point in a list of 3D points that is closest to a test point.
Public methodStatic memberPoint3dKNeighbors
Finds a certain amount of points in a list of 3D points that are the k-closest to a test point.
Public methodStatic memberPointCloudClosestPoints
Finds the point in a list of 3D points that is closest to a test point.
Public methodStatic memberPointCloudKNeighbors
Finds a certain amount of points in a list of 3D points that are the k-closest to a test point.
Public methodRemove(BoundingBox, Int32)
Removes an element from the tree.
Public methodRemove(BoundingBox, IntPtr)
Removes an element from the tree.
Public methodRemove(Point2d, Int32)
Removes an element from the tree.
Public methodRemove(Point3d, Int32)
Removes an element from the tree.
Public methodRemove(Point3d, IntPtr)
Removes an element from the tree.
Public methodSearch(BoundingBox, EventHandlerRTreeEventArgs)
Searches for items in a bounding box.

The bounding box can be singular and contain exactly one single point.

Public methodSearch(Sphere, EventHandlerRTreeEventArgs)
Searches for items in a sphere.
Public methodSearch(BoundingBox, EventHandlerRTreeEventArgs, Object)
Searches for items in a bounding box.

The bounding box can be singular and contain exactly one single point.

Public methodCode exampleSearch(Sphere, EventHandlerRTreeEventArgs, Object)
Searches for items in a sphere.
Public methodStatic memberSearchOverlaps
Searches two R-trees for all pairs elements whose bounding boxes overlap.
Top
See Also