Click or drag to resize

RTreePoint3dKNeighbors Method

Finds a certain amount of points in a list of 3D points that are the k-closest to a test point.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public static IEnumerable<int[]> Point3dKNeighbors(
	IEnumerable<Point3d> hayPoints,
	IEnumerable<Point3d> needlePts,
	int amount
)

Parameters

hayPoints
Type: System.Collections.GenericIEnumerablePoint3d
A series of points.
needlePts
Type: System.Collections.GenericIEnumerablePoint3d
Points to search for.
amount
Type: SystemInt32
The required amount of closest neighbors to find.

Return Value

Type: IEnumerableInt32
An enumerable of arrays of indices; each array contains the indices for each of the needlePts.
See Also