Click or drag to resize

RTreePoint3dClosestPoints Method

Finds the point in a list of 3D points that is closest to a test point.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public static IEnumerable<int[]> Point3dClosestPoints(
	IEnumerable<Point3d> hayPoints,
	IEnumerable<Point3d> needlePts,
	double limitDistance
)

Parameters

hayPoints
Type: System.Collections.GenericIEnumerablePoint3d
A series of points.
needlePts
Type: System.Collections.GenericIEnumerablePoint3d
Points to search for.
limitDistance
Type: SystemDouble
The maximum allowed distance.

Return Value

Type: IEnumerableInt32
An enumerable of arrays of indices; each array contains the indices for each of the needlePts.
See Also