ViewportInfoGetSphereDepth Method |
Gets near and far clipping distances of a bounding sphere.
Namespace:
Rhino.DocObjects
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool GetSphereDepth(
Sphere sphere,
out double nearDistance,
out double farDistance
)
Public Function GetSphereDepth (
sphere As Sphere,
<OutAttribute> ByRef nearDistance As Double,
<OutAttribute> ByRef farDistance As Double
) As Boolean
Parameters
- sphere
- Type: Rhino.GeometrySphere
The sphere to sample. - nearDistance
- Type: SystemDouble
Near distance of the sphere (can be < 0) - farDistance
- Type: SystemDouble
Far distance of the sphere (can be equal to near_dist)
Return Value
Type:
Booleantrue if the sphere intersects the view frustum and near_dist/far_dist were set.
false if the sphere does not intersect the view frustum.
See Also