RhinoCommon API
RhinoCommon API
Namespaces
Rhino.DocObjects
ViewportInfo Class
ViewportInfo Methods
CalculateCameraRotationAngle Method
CalculateCameraUpDirection Method
ChangeToParallelProjection Method
ChangeToPerspectiveProjection Method
ChangeToSymmetricFrustum Method
ChangeToTwoPointPerspectiveProjection Method
DollyCamera Method
DollyExtents Method
DollyFrustum Method
Extents Method
FrustumCenterPoint Method
GetBoundingBoxDepth Method
GetCameraAngles Method
GetCameraFrame Method
GetDollyCameraVector Method
GetFarPlaneCorners Method
GetFramePlaneCorners Method
GetFrustum Method
GetFrustumLine Method
GetNearPlaneCorners Method
GetPointDepth Method
GetScreenPort Method
GetScreenPortLocation Method
GetSphereDepth Method
GetViewScale Method
GetWorldToScreenScale Method
GetXform Method
RotateCamera Method
SetCameraDirection Method
SetCameraLocation Method
SetCameraUp Method
SetFrustum Method
SetFrustumNearFar Method
SetScreenPort Method
SetViewScale Method
TargetDistance Method
TransformCamera Method
UnlockCamera Method
UnlockFrustumSymmetry Method
ZoomToScreenRect Method
ViewportInfo
UnlockCamera Method
Unlocks the camera vectors and location.
Namespace:
Rhino.DocObjects
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since:
5.0
Syntax
C#
VB
Copy
public
void
UnlockCamera
()
Public
Sub
UnlockCamera
See Also
Reference
ViewportInfo Class
Rhino.DocObjects Namespace
Rhino 8.12.24282.07000 (2024-10-08)
Copyright © 2009-2024 Robert McNeel & Associates
Report wishes and bugs at discourse.mcneel.com