Click or drag to resize

ViewportInfoGetBoundingBoxDepth Method

Gets near and far clipping distances of a bounding box. This function ignores the current value of the viewport's near and far settings. If the viewport is a perspective projection, the it intersects the semi infinite frustum volume with the bounding box and returns the near and far distances of the intersection. If the viewport is a parallel projection, it intersects the infinite view region with the bounding box and returns the near and far distances of the projection.

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool GetBoundingBoxDepth(
	BoundingBox bbox,
	out double nearDistance,
	out double farDistance
)

Parameters

bbox
Type: Rhino.GeometryBoundingBox
The bounding box to sample.
nearDistance
Type: SystemDouble
Near distance of the box. This value can be zero or negative when the camera location is inside box.
farDistance
Type: SystemDouble
Far distance of the box. This value can be equal to near_dist, zero or negative when the camera location is in front of the bounding box.

Return Value

Type: Boolean
true if the bounding box intersects the view frustum and near_dist/far_dist were set. false if the bounding box does not intersect the view frustum.
See Also