Click or drag to resize

GroupTable Class

Group tables store the list of groups in a Rhino document.
Inheritance Hierarchy
SystemObject
  Rhino.FileIOCommonComponentTableGroup
    Rhino.DocObjects.TablesRhinoDocCommonTableGroup
      Rhino.DocObjects.TablesGroupTable

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class GroupTable : RhinoDocCommonTable<Group>, 
	ICollection<Group>, IEnumerable<Group>, IEnumerable

The GroupTable type exposes the following members.

Properties
Methods
  NameDescription
Public methodAdd
Adds a new empty group to the group table.
Public methodCode exampleAdd(IEnumerableGuid)
Adds a new group to the group table with a set of objects.
Public methodAdd(String)
Adds a new empty group to the group table.
Public methodAdd(String, IEnumerableGuid)
Adds a new group to the group table with a set of objects.
Public methodAddToGroup(Int32, IEnumerableGuid)
Adds a list of objects to an existing group.
Public methodAddToGroup(Int32, Guid)
Adds an object to an existing group.
Public methodChangeGroupName
Changes the name of a group.
Public methodDelete(Group) (Overrides CommonComponentTableTDelete(T).)
Public methodDelete(Int32)
Deletes a group from this table.

Deleted groups are kept in the runtime group table so that undo will work with groups. Call IsDeleted() to determine if a group is deleted.

Public methodFindIndex
Retrieves a Group object based on Index. This search type of search is discouraged. We are moving towards using only IDs for all tables.
Public methodFindName
Finds a group given its name. Returns the instance, rather than the index.
Public methodFindNameHash
Finds a group given its name hash.
Public methodGroupMembers
Gets an array of all of the objects in a group.
Public methodGroupName
Returns the name of a group.
Public methodGroupNames
Returns an array of all group names.
Public methodGroupObjectCount
Returns the number of objects that are members of a group.
Public methodHide
Hides all objects that are members of a group.
Public methodIsDeleted
Verifies a group is deleted.
Public methodLock
Locks all objects that are members of a group.
Public methodShow
Shows, or unhides, all objects that are members of a group.
Public methodUndelete
Undeletes a previously deleted group.
Public methodUnlock
Unlocks all objects that are members of a group.
Top
See Also