Click or drag to resize

Plane Methods

The Plane type exposes the following members.

Methods
  NameDescription
Public methodClone
Returns a deep copy of this instance.
Public methodCode exampleClosestParameter
Gets the parameters of the point on the plane closest to a test point.
Public methodClosestPoint
Gets the point on the plane closest to a test point.
Public methodStatic memberCreateFromFrame
Constructs a plane from a point, and two vectors in the plane.
Public methodStatic memberCreateFromNormal
Constructs a plane from a point and normal vector.
Public methodStatic memberCreateFromNormalYup
Construct a plane from a point, a normal vector, and a vector that projects to the positive YAxis.
Public methodStatic memberCreateFromPoints
Construct a plane from three non-collinear points.
Public methodCode exampleDistanceTo(Point3d)
Returns the signed distance from testPoint to its projection onto this plane. If the point is below the plane, a negative distance is returned.
Public methodDistanceTo(BoundingBox, Double, Double)
Returns the signed minimum and maximum distances from bounding box to this plane.
Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodEquals(Object)
Determines if an object is a plane and has the same components as this plane.
(Overrides ValueTypeEquals(Object).)
Public methodEquals(Plane)
Determines if another plane has the same components as this plane.
Public methodExtendThroughBox(BoundingBox, Interval, Interval)
Extends this plane through a bounding box.
Public methodExtendThroughBox(Box, Interval, Interval)
Extend this plane through a Box.
Public methodStatic memberFitPlaneToPoints(IEnumerablePoint3d, Plane)
Fit a plane through a collection of points.
Public methodStatic memberFitPlaneToPoints(IEnumerablePoint3d, Plane, Double)
Fit a plane through a collection of points.
Public methodFlip
Flip this plane by swapping out the X and Y axes and inverting the Z axis.
Public methodGetHashCode
Gets a non-unique hashing code for this entity.
(Overrides ValueTypeGetHashCode.)
Public methodGetPlaneEquation
Gets the plane equation for this plane in the format of Ax+By+Cz+D=0.
Public methodIsCoplanar(Plane)
Test if this plane is co-planar with a another plane.
Public methodIsCoplanar(Plane, Double)
Test if this plane is co-planar with a another plane.
Public methodPointAt(Double, Double)
Evaluate a point on the plane.
Public methodPointAt(Double, Double, Double)
Evaluate a point on the plane.
Public methodRemapToPlaneSpace
Convert a point from World space coordinates into Plane space coordinates.
Public methodRotate(Double, Vector3d)
Rotate the plane about its origin point.
Public methodRotate(Double, Vector3d, Point3d)
Rotate the plane about a custom anchor point.
Public methodRotate(Double, Double, Vector3d)
Rotate the plane about its origin point.
Public methodRotate(Double, Double, Vector3d, Point3d)
Rotate the plane about a custom anchor point.
Public methodToString
Constructs the string representation of this plane.
(Overrides ValueTypeToString.)
Public methodToString(String, IFormatProvider)
Formats the value of the current instance using the specified format.
Public methodTransform
Transform the plane with a Transformation matrix.
Public methodTranslate
Translate (move) the plane along a vector.
Public methodUpdateEquation
Update Equations
Public methodValueAt
Get the value of the plane equation at the point.
Top
See Also