Click or drag to resize

PlaneFitPlaneToPoints Method (IEnumerablePoint3d, Plane)

Fit a plane through a collection of points.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static PlaneFitResult FitPlaneToPoints(
	IEnumerable<Point3d> points,
	out Plane plane
)

Parameters

points
Type: System.Collections.GenericIEnumerablePoint3d
Points to fit to.
plane
Type: Rhino.GeometryPlane
Resulting plane.

Return Value

Type: PlaneFitResult
A value indicating the result of the operation.
See Also