PlaneRotate Method (Double, Double, Vector3d) |
Rotate the plane about its origin point.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool Rotate(
double sinAngle,
double cosAngle,
Vector3d axis
)
Public Function Rotate (
sinAngle As Double,
cosAngle As Double,
axis As Vector3d
) As Boolean
Parameters
- sinAngle
- Type: SystemDouble
Sin(angle). - cosAngle
- Type: SystemDouble
Cos(angle). - axis
- Type: Rhino.GeometryVector3d
Axis of rotation.
Return Value
Type:
Booleantrue on success, false on failure.
See Also