PlaneRotate Method (Double, Vector3d, Point3d) |
Rotate the plane about a custom anchor point.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool Rotate(
double angle,
Vector3d axis,
Point3d centerOfRotation
)
Public Function Rotate (
angle As Double,
axis As Vector3d,
centerOfRotation As Point3d
) As Boolean
Parameters
- angle
- Type: SystemDouble
Angle in radians. - axis
- Type: Rhino.GeometryVector3d
Axis of rotation. - centerOfRotation
- Type: Rhino.GeometryPoint3d
Center of rotation.
Return Value
Type:
Booleantrue on success, false on failure.
See Also