Click or drag to resize

ArchivableDictionaryTryGetEnumValueT Method

Attempt to get an enum value from the dictionary using a custom key.

Namespace:  Rhino.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.4
Syntax
public bool TryGetEnumValue<T>(
	string key,
	out T enumValue
)
where T : struct, new(), IConvertible

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Rhino.Collections.ArchivableDictionary.TryGetEnumValue``1(System.String,``0@)"]

enumValue
Type: T

[Missing <param name="enumValue"/> documentation for "M:Rhino.Collections.ArchivableDictionary.TryGetEnumValue``1(System.String,``0@)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Rhino.Collections.ArchivableDictionary.TryGetEnumValue``1(System.String,``0@)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Rhino.Collections.ArchivableDictionary.TryGetEnumValue``1(System.String,``0@)"]

See Also