RhinoCommon API
RhinoCommon API
Namespaces
Rhino.Collections
ArchivableDictionary Class
ArchivableDictionary Methods
AddContentsFrom Method
Clear Method
Clone Method
ContainsKey Method
GetBool Method
GetBytes Method
GetDictionary Method
GetDouble Method
GetEnumerator Method
GetEnumValue Method
GetFloat Method
GetGuid Method
Getint Method
GetInteger Method
GetObjectData Method
GetPlane Method
GetPoint3d Method
GetPoint3f Method
GetString Method
GetVector3d Method
Remove Method
RemoveEnumValue(T) Method
ReplaceContentsWith Method
Set Method
SetEnumValue Method
TryGetBool Method
TryGetBytes Method
TryGetDictionary Method
TryGetDouble Method
TryGetEnumValue(T) Method
TryGetFloat Method
TryGetGuid Method
TryGetInteger Method
TryGetPlane Method
TryGetPoint3d Method
TryGetPoint3f Method
TryGetString Method
TryGetValue Method
TryGetVector3d Method
ArchivableDictionary
Clear Method
Removes all keys and values from the dictionary.
Namespace:
Rhino.Collections
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since:
5.0
Syntax
C#
VB
Copy
public
void
Clear
()
Public
Sub
Clear
Implements
ICollection
T
Clear
See Also
Reference
ArchivableDictionary Class
Rhino.Collections Namespace
Rhino 8.13.24317.13000 (2024-11-12)
Copyright © 2009-2024 Robert McNeel & Associates
Report wishes and bugs at discourse.mcneel.com