MeshVertexNormalList Class |
Namespace: Rhino.Geometry.Collections
The MeshVertexNormalList type exposes the following members.
Name | Description | |
---|---|---|
![]() | Capacity |
Gets or sets the amount of vertex normals that the list can hold without resizing.
|
![]() | Count |
Gets or sets the number of mesh vertex normals.
|
![]() | Item |
Gets or sets the vertex at the given index.
The index must be valid or an IndexOutOfRangeException will be thrown.
|
Name | Description | |
---|---|---|
![]() | Add(Vector3d) |
Adds a new vertex normal at the end of the list.
|
![]() | Add(Vector3f) |
Adds a new vertex normal at the end of the list.
|
![]() | Add(Double, Double, Double) |
Adds a new vertex normal at the end of the list.
|
![]() | Add(Single, Single, Single) |
Adds a new vertex normal at the end of the list.
|
![]() | AddRange |
Appends a collection of normal vectors.
|
![]() | Clear |
Clears the vertex normal collection on the mesh.
|
![]() ![]() | ComputeNormals |
Computes the vertex normals based on the physical shape of the mesh.
|
![]() | Destroy |
Releases all memory allocated to store vertex normals. The list capacity will be 0 after this call.
Subsequent calls can add new items. |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) |
![]() | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.) |
![]() | Flip |
Reverses direction of all vertex normals
This is the same as Mesh.Flip(true, false, false) |
![]() | GetEnumerator |
Gets an enumerator that yields all normals (vectors) in this collection.
|
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object.) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) |
![]() | SetNormal(Int32, Vector3d) |
Sets or adds a vertex normal to the list.
If [index] is less than [Count], the existing vertex normal at [index] will be modified. If [index] equals [Count], a new vertex normal is appended to the end of the list. If [index] is larger than [Count], the function will return false. |
![]() | SetNormal(Int32, Vector3f) |
Sets or adds a vertex normal to the list.
If [index] is less than [Count], the existing vertex normal at [index] will be modified. If [index] equals [Count], a new vertex normal is appended to the end of the vertex list. If [index] is larger than [Count], the function will return false. |
![]() | SetNormal(Int32, Double, Double, Double) |
Sets or adds a vertex normal to the list.
If [index] is less than [Count], the existing vertex normal at [index] will be modified. If [index] equals [Count], a new vertex normal is appended to the end of the list. If [index] is larger than [Count], the function will return false. |
![]() | SetNormal(Int32, Single, Single, Single) |
Sets or adds a normal to the list.
If [index] is less than [Count], the existing vertex normal at [index] will be modified. If [index] equals [Count], a new vertex normal is appended to the end of the list. If [index] is larger than [Count], the function will return false. |
![]() | SetNormals |
Sets all normal vectors in one go. This method destroys the current normal array if it exists.
|
![]() | ToFloatArray |
Copies all vertex normals to a linear array of float in x,y,z order
|
![]() | ToString | Returns a string that represents the current object. (Inherited from Object.) |
![]() | UnitizeNormals |
Unitizes all vertex normals.
|