Click or drag to resize

MeshVertexNormalList Methods

The MeshVertexNormalList type exposes the following members.

Methods
  NameDescription
Public methodAdd(Vector3d)
Adds a new vertex normal at the end of the list.
Public methodAdd(Vector3f)
Adds a new vertex normal at the end of the list.
Public methodAdd(Double, Double, Double)
Adds a new vertex normal at the end of the list.
Public methodAdd(Single, Single, Single)
Adds a new vertex normal at the end of the list.
Public methodAddRange
Appends a collection of normal vectors.
Public methodClear
Clears the vertex normal collection on the mesh.
Public methodCode exampleComputeNormals
Computes the vertex normals based on the physical shape of the mesh.
Public methodDestroy
Releases all memory allocated to store vertex normals. The list capacity will be 0 after this call.

Subsequent calls can add new items.

Public methodFlip
Reverses direction of all vertex normals

This is the same as Mesh.Flip(true, false, false)

Public methodGetEnumerator
Gets an enumerator that yields all normals (vectors) in this collection.
Public methodSetNormal(Int32, Vector3d)
Sets or adds a vertex normal to the list.

If [index] is less than [Count], the existing vertex normal at [index] will be modified.

If [index] equals [Count], a new vertex normal is appended to the end of the list.

If [index] is larger than [Count], the function will return false.

Public methodSetNormal(Int32, Vector3f)
Sets or adds a vertex normal to the list.

If [index] is less than [Count], the existing vertex normal at [index] will be modified.

If [index] equals [Count], a new vertex normal is appended to the end of the vertex list.

If [index] is larger than [Count], the function will return false.

Public methodSetNormal(Int32, Double, Double, Double)
Sets or adds a vertex normal to the list.

If [index] is less than [Count], the existing vertex normal at [index] will be modified.

If [index] equals [Count], a new vertex normal is appended to the end of the list.

If [index] is larger than [Count], the function will return false.

Public methodSetNormal(Int32, Single, Single, Single)
Sets or adds a normal to the list.

If [index] is less than [Count], the existing vertex normal at [index] will be modified.

If [index] equals [Count], a new vertex normal is appended to the end of the list.

If [index] is larger than [Count], the function will return false.

Public methodSetNormals
Sets all normal vectors in one go. This method destroys the current normal array if it exists.
Public methodToFloatArray
Copies all vertex normals to a linear array of float in x,y,z order
Public methodUnitizeNormals
Unitizes all vertex normals.
Top
See Also