Click or drag to resize

HatchPatternTable Class

All of the hatch pattern definitions contained in a rhino document.
Inheritance Hierarchy
SystemObject
  Rhino.FileIOCommonComponentTableHatchPattern
    Rhino.DocObjects.TablesRhinoDocCommonTableHatchPattern
      Rhino.DocObjects.TablesHatchPatternTable

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class HatchPatternTable : RhinoDocCommonTable<HatchPattern>, 
	ICollection<HatchPattern>, IEnumerable<HatchPattern>, IEnumerable

The HatchPatternTable type exposes the following members.

Properties
  NameDescription
Public propertyComponentType (Overrides CommonComponentTableTComponentType.)
Public propertyCode exampleCurrentHatchPatternIndex
At all times, there is a "current" hatch pattern. Unless otherwise specified, new objects are assigned to the current hatch pattern. The current hatch pattern is never locked, hidden, or deleted.
Public propertyItem
Conceptually, the hatch pattern table is an array of hatch patterns. The operator[] can be used to get individual hatch patterns. A hatch pattern is either active or deleted and this state is reported by HatchPattern.IsDeleted.
Top
Methods
  NameDescription
Public methodAdd
Adds a new hatch pattern with specified definition to the table.
Public methodDelete(HatchPattern)
Deletes a hatch pattern from the table.
(Overrides CommonComponentTableTDelete(T).)
Public methodDelete(Int32)
Deletes a hatch pattern from the table.
Public methodDelete(HatchPattern, Boolean)
Deletes a hatch pattern from the table.
Public methodDelete(Int32, Boolean)
Deletes a hatch pattern from the table.
Public methodCode exampleFind Obsolete.
Finds the hatch pattern with a given name. Search ignores case.
Public methodFindIndex
Retrieves a HatchPattern object based on Index. This search type of search is discouraged. We are moving towards using only IDs for all tables.
Public methodCode exampleFindName
Finds the hatch pattern with a given name. Search ignores case.
Public methodFindNameHash
Finds a HatchPattern given its name hash.
Public methodModify
Modify hatch pattern settings.
Public methodRename(HatchPattern, String)
Renames a hatch pattern in the table.
Public methodRename(Int32, String)
Renames a hatch pattern in the table.
Top
See Also