Click or drag to resize

HatchPatternTable Methods

The HatchPatternTable type exposes the following members.

Methods
  NameDescription
Public methodAdd
Adds a new hatch pattern with specified definition to the table.
Public methodDelete(HatchPattern)
Deletes a hatch pattern from the table.
(Overrides CommonComponentTableTDelete(T).)
Public methodDelete(Int32)
Deletes a hatch pattern from the table.
Public methodDelete(HatchPattern, Boolean)
Deletes a hatch pattern from the table.
Public methodDelete(Int32, Boolean)
Deletes a hatch pattern from the table.
Public methodCode exampleFind Obsolete.
Finds the hatch pattern with a given name. Search ignores case.
Public methodFindIndex
Retrieves a HatchPattern object based on Index. This search type of search is discouraged. We are moving towards using only IDs for all tables.
Public methodCode exampleFindName
Finds the hatch pattern with a given name. Search ignores case.
Public methodFindNameHash
Finds a HatchPattern given its name hash.
Public methodModify
Modify hatch pattern settings.
Public methodRename(HatchPattern, String)
Renames a hatch pattern in the table.
Public methodRename(Int32, String)
Renames a hatch pattern in the table.
Top
See Also