HatchPatternTable Properties |
The HatchPatternTable type exposes the following members.
Name | Description | |
---|---|---|
![]() | ComponentType | (Overrides CommonComponentTableTComponentType.) |
![]() | Count |
Returns the count of all items, including deleted ones.
(Inherited from CommonComponentTableT.) |
![]() ![]() | CurrentHatchPatternIndex |
At all times, there is a "current" hatch pattern. Unless otherwise
specified, new objects are assigned to the current hatch pattern.
The current hatch pattern is never locked, hidden, or deleted.
|
![]() | Document | Document that owns this table. (Inherited from RhinoDocCommonTableT.) |
![]() | Item |
Conceptually, the hatch pattern table is an array of hatch patterns.
The operator[] can be used to get individual hatch patterns. A hatch pattern is
either active or deleted and this state is reported by HatchPattern.IsDeleted.
|