Click or drag to resize

RhinoDoc Methods

The RhinoDoc type exposes the following members.

Methods
  NameDescription
Public methodAddCustomUndoEvent(String, EventHandlerCustomUndoEventArgs)
Public methodCode exampleAddCustomUndoEvent(String, EventHandlerCustomUndoEventArgs, Object)
Add a custom undo event so you can undo private plug-in data when the user performs an undo or redo
Public methodAdjustModelUnitSystem
Public methodAdjustPageUnitSystem
Public methodBeginUndoRecord
Instructs Rhino to begin recording undo information when the document is changed outside of a command. We use this, e.g., to save changes caused by the modeless layer or object properties dialogs when commands are not running.
Public methodClearRedoRecords
Public methodClearUndoRecords(Boolean)
Public methodClearUndoRecords(UInt32, Boolean)
Public methodStatic memberCreate
Creates a new RhinoDoc
Public methodCode exampleCreateDefaultAttributes
Gets the default object attributes for this document. The attributes will be linked to the currently active layer and they will inherit the Document WireDensity setting.
Public methodStatic memberCreateHeadless
Create a new headless RhinoDoc from a template file
Public methodCustomRenderMeshesBoundingBox
Returns the bounding box of custom render primitives for this object .
Public methodDispose
Public methodEndUndoRecord
Ends the undo record.
Public methodEquals (Overrides ObjectEquals(Object).)
Public methodExport(String)
Export the entire document to a file. All file formats that Rhino can export to are supported by this function.
Public methodExport(String, ArchivableDictionary)
Export the entire document to a file. All file formats that Rhino can export to are supported by this function.
Public methodExportSelected(String)
Export selected geometry to a file. All file formats that Rhino can export to are supported by this function.
Public methodExportSelected(String, ArchivableDictionary)
Export selected geometry to a file. All file formats that Rhino can export to are supported by this function.
Public methodStatic memberExtractPreviewImage
Extracts the bitmap preview image from the specified .3dm file.
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodFindFile
Search for a file using Rhino's search path. Rhino will look in the following places: 1. Current model folder 2. Path specified in options dialog/File tab 3. Rhino system folders 4. Rhino executable folder
Public methodFormatNumber(Double)
Call this method to get string representing the specified value using the documents display coordinate system and display precision.
Public methodFormatNumber(Double, Boolean, Boolean)
Call this method to get string representing the specified value using the documents display coordinate system and display precision.
Public methodStatic memberFromFilePath
Search the open document list for a document with a Path equal to the specified file path.
Public methodStatic memberFromId Obsolete.
Public methodStatic memberFromRuntimeSerialNumber
Public methodGetAnalysisMeshingParameters
Get analysis meshing parameters currently used by the document
Public methodGetCurrentMeshingParameters
Get the custom meshing parameters that this document will use.
Public methodGetCustomUnitSystem
Get the custom unit system name and custom unit scale.
Public methodGetEmbeddedFilesList
Public methodGetGridDefaults
Public methodGetGumballPlane
Returns the active plane of Rhino's auto-gumball widget. Note, when calling from a Rhino command, make sure the command class has the Rhino.Commands.Style.Transparent command style attribute.
Public methodGetHashCode (Overrides ObjectGetHashCode.)
Public methodGetMeshingParameters
Get MeshingParameters currently used by the document
Public methodGetRenderPrimitiveList Obsolete.
Build custom render mesh(es) for this document (i.e. - GH meshes).
Public methodGetRenderPrimitives(Boolean, Boolean) Obsolete.
Get a enumerable list of custom mesh primitives
Public methodGetRenderPrimitives(ViewportInfo, Boolean, Boolean) Obsolete.
Get a enumerable list of custom mesh primitives
Public methodGetRenderPrimitives(Guid, ViewportInfo, Boolean, Boolean) Obsolete.
Get a enumerable list of custom mesh primitives
Public methodGetUnitSystemName
Public methodHasCustomRenderMeshes
Returns true if the document has a set of custom render primitives - ie, CustomRenderMeshes will return non-null.
Public methodImport(String)
Import geometry into a RhinoDoc from a file. This can be any file format that Rhino can import
Public methodImport(String, ArchivableDictionary)
Import geometry into a RhinoDoc from a file. This can be any file format that Rhino can import
Public methodInCommand
This is a low level tool to determine if Rhino is currently running a command.
Public methodIsMetricUnitSystem
Determines if a document unit system is a metric unit system.
Public methodStatic memberOpen
Opens a 3dm file and makes it the active document. If called on windows the active document will be saved and closed and the new document will be opened and become the active document. If called on the Mac the file will be opened in a new document window.
Public methodStatic memberOpenDocuments
Returns a list of currently open Rhino documents
Public methodStatic memberOpenDocuments(Boolean)
Returns a list of currently open Rhino documents
Public methodStatic memberOpenFile Obsolete.
Public methodStatic memberOpenHeadless
Opens a 3DM file into a new headless RhinoDoc.
Public methodStatic memberReadFile
Public methodReadFileVersion
Returns the file version of the current document. Use this function to determine which version of Rhino last saved the document.
Public methodRedo
Redo the last action that was "undone"
Public methodRenderMeshes
Returns a set of non-object custom render primitives for this document.
Public methodSave
Save doc to disk using the document's Path
Public methodSaveAs(String)
Save doc as a 3dm to a specified path using the current Rhino file version
Public methodSaveAs(String, Int32)
Save doc as a 3dm to a specified path
Public methodSaveAs(String, Int32, Boolean, Boolean, Boolean, Boolean)
Save doc as a 3dm to a specified path
Public methodSaveAsTemplate(String)
Save this document as a template
Public methodSaveAsTemplate(String, Int32)
Save this document as a template to a specific Rhino file version
Public methodSelectRenderContentInEditor
Selects a collection of contents in any editors they appear in.
Public methodSetCustomMeshingParameters
Set the custom meshing parameters that this document will use. You must also modify the MeshingParameterStyle property on the document to Custom if you want these meshing parameters to be used
Public methodSetCustomUnitSystem
Changes the unit system to custom units and sets the custom unit scale.
Public methodSetGridDefaults
Public methodSupportsRenderPrimitiveList Obsolete.
Determines if custom render meshes will be built for this document (i.e. - GH meshes).
Public methodTryGetRenderPrimitiveBoundingBox Obsolete.
Get the bounding box for the custom render meshes associated with this document (i.e. - GH meshes).
Public methodUndo
Undo the last action
Public methodWrite3dmFile
Write information in this document to a .3dm file. Note, the active document's name will not be changed.
Public methodWriteFile
Write information in this document to a file. Note, the active document's name will be changed to that of the path provided.
Top
See Also