Click or drag to resize

RhinoDocRenderMeshes Method

Returns a set of non-object custom render primitives for this document.

Namespace:  Rhino
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 8.0
Syntax
public RenderMeshes[] RenderMeshes(
	MeshType mt,
	ViewportInfo vp,
	ref RenderMeshProviderFlags flags,
	PlugIn plugin,
	DisplayPipelineAttributes attrs
)

Parameters

mt
Type: Rhino.GeometryMeshType
The mesh type requested (render or analysis).
vp
Type: Rhino.DocObjectsViewportInfo
The viewport being rendered
flags
Type: Rhino.Render.CustomRenderMeshesRenderMeshProviderFlags
See MeshProvider.Flags
plugin
Type: Rhino.PlugInsPlugIn
The requesting plug-in (typically the calling plugin)
attrs
Type: Rhino.DisplayDisplayPipelineAttributes
Display attributes for the caller - null if this is a full rendering.

Return Value

Type: RenderMeshes
Returns a set of custom render primitives for this object
See Also