Write information in this document to a file.
Note, the active document's name will be changed to that
of the path provided.
Namespace:
Rhino
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool WriteFile(
string path,
FileWriteOptions options
)
Public Function WriteFile (
path As String,
options As FileWriteOptions
) As Boolean
Parameters
- path
- Type: SystemString
The name of the file to write. - options
- Type: Rhino.FileIOFileWriteOptions
The file writing options.
Return Value
Type:
Booleantrue if successful, false on failure.
Remarks
This is the best choice for general file writing.
It handles making backups using temporary files,
locking and unlocking, loading file writing plug-ins,
and many other details.
See Also