Audits the contents of the document.
Namespace:
Rhino
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 8.19
Syntaxpublic bool Audit(
TextLog textLog,
bool attemptRepair
)
Public Function Audit (
textLog As TextLog,
attemptRepair As Boolean
) As Boolean
Parameters
- textLog
- Type: Rhino.FileIOTextLog
If an error is detected, then a description of the error is logged here. - attemptRepair
- Type: SystemBoolean
If true, then the method attempts to repair any detected errors.
Return Value
Type:
BooleanTrue if document is valid.
See Also