RhinoDocHasCustomRenderMeshes Method |
Returns true if the document has a set of custom render primitives - ie, CustomRenderMeshes will return non-null.
Namespace:
Rhino
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 8.0
Syntax public bool HasCustomRenderMeshes(
MeshType mt,
ViewportInfo vp,
ref RenderMeshProviderFlags flags,
PlugIn plugin,
DisplayPipelineAttributes attrs
)
Public Function HasCustomRenderMeshes (
mt As MeshType,
vp As ViewportInfo,
ByRef flags As RenderMeshProviderFlags,
plugin As PlugIn,
attrs As DisplayPipelineAttributes
) As Boolean
Parameters
- mt
- Type: Rhino.GeometryMeshType
The mesh type requested (render or analysis). - vp
- Type: Rhino.DocObjectsViewportInfo
The viewport being rendered. - flags
- Type: Rhino.Render.CustomRenderMeshesRenderMeshProviderFlags
See MeshProvider.Flags - plugin
- Type: Rhino.PlugInsPlugIn
The requesting plug-in (typically the calling plugin) - attrs
- Type: Rhino.DisplayDisplayPipelineAttributes
Display attributes for the caller - null if this is a full rendering.
Return Value
Type:
BooleanReturns true if the object will has a set of custom render primitives
See Also