Click or drag to resize

NurbsCurveKnotList Methods

The NurbsCurveKnotList type exposes the following members.

Methods
  NameDescription
Public methodClampEnd
Clamp end knots. Does not modify control point locations.
Public methodContains
Returns an indication of the presence of a value in the knot list.
Public methodCopyTo
Copies the list to an array.
Public methodCreatePeriodicKnots
Compute a clamped, uniform, periodic knot vector based on the current degree and control point count. Does not change values of control vertices.
Public methodCreateUniformKnots
Compute a clamped, uniform knot vector based on the current degree and control point count. Does not change values of control vertices.
Public methodEnsurePrivateCopy
If you want to keep a copy of this class around by holding onto it in a variable after a command completes, call EnsurePrivateCopy to make sure that this class is not tied to the document. You can call this function as many times as you want.
Public methodEpsilonEquals
Checks that all values in the other list are sequentially equal within epsilon to the values in this list.
Public methodIndexOf
Returns the first item in the list.
Public methodCode exampleInsertKnot(Double)
Inserts a knot and update control point locations. Does not change parameterization or locus of curve.
Public methodInsertKnot(Double, Int32)
Inserts a knot and update control point locations. Does not change parameterization or locus of curve.
Public methodKnotMultiplicity
Get knot multiplicity.
Public methodRemoveKnotAt
Remove a knot from a curve and adjusts the remaining control points to maintain curve position as closely as possible.
Public methodRemoveKnots
Remove knots from a curve and adjusts the remaining control points to maintain curve position as closely as possible. The knots from Knots[index0] through Knots[index1 - 1] will be removed.
Public methodRemoveMultipleKnots
Remove multiple knots from this curve.
Public methodSuperfluousKnot
Computes the knots that are superfluous because they are not used in NURBs evaluation. These make it appear so that the first and last curve spans are different from interior spans.

http://wiki.mcneel.com/developer/onsuperfluousknot

Top
See Also