Click or drag to resize

NurbsCurveKnotListSuperfluousKnot Method

Computes the knots that are superfluous because they are not used in NURBs evaluation. These make it appear so that the first and last curve spans are different from interior spans.

http://wiki.mcneel.com/developer/onsuperfluousknot

Namespace:  Rhino.Geometry.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public double SuperfluousKnot(
	bool start
)

Parameters

start
Type: SystemBoolean
true if the query targets the first knot. Otherwise, the last knot.

Return Value

Type: Double
A component.
See Also