NurbsCurveKnotListRemoveKnotAt Method |
Remove a knot from a curve and adjusts the remaining control points to maintain curve position as closely as possible.
Namespace:
Rhino.Geometry.Collections
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax public bool RemoveKnotAt(
double t
)
Public Function RemoveKnotAt (
t As Double
) As Boolean
Parameters
- t
- Type: SystemDouble
The parameter on the curve that is closest to the knot to be removed.
Return Value
Type:
Booleantrue if successful, false on failure.
See Also