NurbsCurveKnotListInsertKnot Method (Double, Int32) |
Inserts a knot and update control point locations.
Does not change parameterization or locus of curve.
Namespace:
Rhino.Geometry.Collections
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool InsertKnot(
double value,
int multiplicity
)
Public Function InsertKnot (
value As Double,
multiplicity As Integer
) As Boolean
Parameters
- value
- Type: SystemDouble
Knot value to insert. - multiplicity
- Type: SystemInt32
Multiplicity of knot to insert.
Return Value
Type:
Booleantrue on success, false on failure.
See Also