Click or drag to resize

Circle Methods

The Circle type exposes the following members.

Methods
  NameDescription
Public methodClosestParameter
Gets the parameter on the circle which is closest to a test point.
Public methodClosestPoint
Gets the point on the circle which is closest to a test point.
Public methodDerivativeAt
Determines the value of the Nth derivative at a parameter.
Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodIsInPlane
Evaluates whether or not this circle is co-planar with a given plane.
Public methodPointAt
Circles use trigonometric parameterization: t -> center + cos(t)*radius*xaxis + sin(t)*radius*yaxis.
Public methodReverse
Reverse the orientation of the circle. Changes the domain from [a,b] to [-b,-a].
Public methodRotate(Double, Vector3d)
Rotates the circle through a given angle.
Public methodRotate(Double, Vector3d, Point3d)
Rotates the circle through a given angle.
Public methodRotate(Double, Double, Vector3d)
Rotates the circle around an axis that starts at the base plane origin.
Public methodRotate(Double, Double, Vector3d, Point3d)
Rotates the circle around an axis that starts at the provided point.
Public methodTangentAt
Circles use trigonometric parameterization: t -> center + cos(t)*radius*xaxis + sin(t)*radius*yaxis.
Public methodToNurbsCurve
Constructs a nurbs curve representation of this circle. This amounts to the same as calling NurbsCurve.CreateFromCircle().
Public methodToNurbsCurve(Int32, Int32)
Create a uniform non-rational cubic NURBS approximation of a circle.
Public methodTransform
Transforms this circle using an transformation matrix.
Public methodTranslate
Moves the circle.
Public methodStatic memberTryFitCircleToPoints
Attempt to fit a circle through a set of points.
Public methodStatic memberTryFitCircleTT
Try to fit a circle to two curves using tangent relationships.
Public methodStatic memberTryFitCircleTTT
Try to fit a circle to three curves using tangent relationships.
Public methodStatic memberTrySmallestEnclosingCircle
Attempt to create the smallest circle enclosing a set of planar points.
Top
See Also