Click or drag to resize

CirclePointAt Method

Circles use trigonometric parameterization: t -> center + cos(t)*radius*xaxis + sin(t)*radius*yaxis.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Point3d PointAt(
	double t
)

Parameters

t
Type: SystemDouble
Parameter of point to evaluate.

Return Value

Type: Point3d
The point on the circle at the given parameter.
See Also