Click or drag to resize

CircleRotate Method (Double, Vector3d, Point3d)

Rotates the circle through a given angle.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool Rotate(
	double angle,
	Vector3d axis,
	Point3d point
)

Parameters

angle
Type: SystemDouble
Angle (in radians) of the rotation.
axis
Type: Rhino.GeometryVector3d
Rotation axis.
point
Type: Rhino.GeometryPoint3d
Rotation anchor point.

Return Value

Type: Boolean
true on success, false on failure.
See Also