Click or drag to resize

CircleRotate Method (Double, Double, Vector3d, Point3d)

Rotates the circle around an axis that starts at the provided point.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool Rotate(
	double sinAngle,
	double cosAngle,
	Vector3d axis,
	Point3d point
)

Parameters

sinAngle
Type: SystemDouble
The value returned by Math.Sin(angle) to compose the rotation.
cosAngle
Type: SystemDouble
The value returned by Math.Cos(angle) to compose the rotation.
axis
Type: Rhino.GeometryVector3d
A rotation direction.
point
Type: Rhino.GeometryPoint3d
A rotation base point.

Return Value

Type: Boolean
true on success, false on failure.
See Also