CircleRotate Method (Double, Vector3d) |
Rotates the circle through a given angle.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool Rotate(
double angle,
Vector3d axis
)
Public Function Rotate (
angle As Double,
axis As Vector3d
) As Boolean
Parameters
- angle
- Type: SystemDouble
Angle (in radians) of the rotation. - axis
- Type: Rhino.GeometryVector3d
Rotation axis.
Return Value
Type:
Booleantrue on success, false on failure.
See Also