Click or drag to resize

RenderPlugIn Class

A Rhino rendering plugin; applies materials, textures, and lights to a scene to produce rendered images.
Inheritance Hierarchy

Namespace:  Rhino.PlugIns
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class RenderPlugIn : PlugIn

The RenderPlugIn type exposes the following members.

Constructors
  NameDescription
Protected methodRenderPlugIn
Initializes a new instance of the RenderPlugIn class
Top
Properties
  NameDescription
Protected propertyInitialChannelToDisplay
Public propertyPerferBasicContent
Set to true if you would like Rhino to quickly create a basic render content in response to 'Create New' commands. Set to false if you would prefer Rhino to display the render content chooser dialog.
Protected propertySupportedChannels
Override to communicate that the renderer supports more channels beside the default channels RGBA, Depth, Normal, Albedo. See RenderWindow.StandardChannels. RenderWindow.ChannelId can be used to get the GUIDs for the channels to support
Protected propertySupportsEditProperties
Top
Methods
  NameDescription
Protected methodAllowChooseContent
Default implementation returns true which means the content can be picked from the content browser by the user. Override this method and return false if you don't want to allow a certain content contentType to be picked from the content browser while your render engine is current.
Protected methodCreatePreview
Creates the preview bitmap that will appear in the content editor's thumbnail display when previewing materials and environments. If this function is not overridden or the PreviewImage is not set on the arguments, then the internal OpenGL renderer will generate a simulation of the content. This function is called with four different preview quality settings. The first quality level of RealtimeQuick is called on the main thread and needs to be drawn as fast as possible. This function is called with the other three quality settings on a separate thread and are meant for generating progressively refined preview.
Protected methodCreateTexture2dPreview
Creates the preview bitmap that will appear in the content editor's thumbnail display when previewing textures in 2d (UV) mode. If this function is not overridden or the PreviewImage is not set on the arguments, then the internal OpenGL renderer will generate a simulation.
Public methodStatic memberCurrentRendererSupportsFeature
Protected methodCustomChannelName
Return the localized name of your custom channel.
Public methodEnableAssignMaterialButton
Called to enable/disable the "Material" button located on the "Material" tab in the Properties and Layer dialog boxes. The default return value is false which will disable the button. If the button is disabled then the OnAssignMaterial function is never called.
Public methodEnableCreateMaterialButton
Called to enable/disable the "New" button located on the "Material" in the Properties and Layer dialog boxes. The default return value is false which will disable the button. If the button is disabled then the OnEditMaterial function is never called.
Public methodEnableEditMaterialButton
Called to enable/disable the "Edit" button located on the "Material" in the Properties and Layer dialog boxes. The default return value is false which will disable the button. If the button is disabled then the OnEditMaterial function is never called.
Public methodGetRenderSettingsSections
This function returns a list of Guids for the render settings pages that should be displayed.
Protected methodInitializeDecalProperties
Initialize your custom decal properties here. The input list will be empty - add your default named property values and return.
Public methodOnAssignMaterial
This function is called by the Object Properties and Layer Control dialogs when the "Material" button is pressed in the "Render" tab. This is only called if EnableAssignMaterialButton returns true.
Public methodOnCreateMaterial
This function is called by the Object Properties and Layer Control dialogs when the "New" button is pressed in the "Material" tab. This is only called if EnableCreateMaterialButton returns true.
Public methodOnEditMaterial
This function is called by the Object Properties and Layer Control dialogs when the "Edit" button is pressed in the "Material" tab. This is only called if EnableEditMaterialButton returns true. A return value of true means the material has been updated.
Protected methodOnSetCurrent
This plug-in (has become)/(is no longer) the current render plug-in
Protected methodPreviewRenderType
Tell what kind of preview rendering your renderer supports.
Protected methodRegisterCustomRenderSaveFileTypes
Override this method to add custom file types to the render window save file dialog.
Protected methodRegisterRenderPanels
Override this method and call RegisterPanel(PlugIn, RenderPanelType, Type, String, Boolean, Boolean) to add custom render UI to the render output window.
Protected methodRegisterRenderTabs
Override this method and call RegisterTab(PlugIn, Type, Guid, String, Icon) to add custom tabs to the render output window
Protected methodRender
Called by Render and RenderPreview commands if this plug-in is set as the default render engine.
Protected methodRenderContentSerializers
Called by Rhino when it is time to register RenderContentSerializer derived classes. Override this method and return an array of an instance of each serialize custom content object you wish to add.
Protected methodRenderOptionsDialogPage
Override this method to replace the render properties page in the Rhino document properties dialog. The default implementation returns null which means just use the default Rhino page.
Public methodRenderSettingsCustomSections
Override this function to provide custom sections for the render settings panel that are displayed when your plug-in is the current render plug-in.
Protected methodRenderSettingsSections
Override this method to provide the UUIDs of all sections that should be displayed in the Render Settings tab when this is the current renderer.The default implementation adds all the RDK's built-in Render Settings sections. These UUIDs start with the prefix uuidRenderSettingsSection'. They can be found in RhRdkUuids.h
Protected methodRenderWindow(RhinoDoc, RunMode, Boolean, RhinoView, Rectangle, Boolean)
This function is obsolete and only exists for legacy purposes. Do not override this function - prefer overriding the version with the blowup parameter.
Protected methodRenderWindow(RhinoDoc, RunMode, Boolean, RhinoView, Rectangle, Boolean, Boolean)
Protected methodShowDecalProperties
Override this function to handle showing a modal dialog with your plug-in's custom decal properties. You will be passed the current properties for the object being edited. The defaults will be set in InitializeDecalProperties.
Public methodSunCustomSections
Override this function to provide custom sections for the sun panel that are displayed when your plug-in is the current render plug-in.
Protected methodSupportedOutputTypes
Returns a list of output types which your renderer can write.

The default implementation returns BMP, JPG, PNG, TIF, TGA, HDR, EXR and RIMAGE.

Protected methodSupportsFeature
Determines if your renderer supports a specific feature.
Protected methodUiContentTypes
Override this method to provide the UUIDs of all content types that should be presented to the user in the types combo box or the[+] button types menu.The default implementation adds only RDK's built-in types. Rhino automatically adds types in the most efficient way to minimize the list length. If you override this method, you may call the base class first to add the built-in types, a separator will be inserted at the end of the standard list followed by your own types. You may omit the base class call and only chosen types yourself, followed by a separator and your own types. A 'More Types...' item is automatically added when needed by Rhino. Specify a separator by adding uuidUiContentType_Separator.
Top
Events
  NameDescription
Top
See Also