Click or drag to resize

PlugInDocumentPropertiesDialogPages Method

Override this function if you want to extend the document properties sections of the options dialog. This function is called whenever the user brings up the Options dialog.

Namespace:  Rhino.PlugIns
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
protected virtual void DocumentPropertiesDialogPages(
	RhinoDoc doc,
	List<OptionsDialogPage> pages
)

Parameters

doc
Type: RhinoRhinoDoc
document that the pages are set up for
pages
Type: System.Collections.GenericListOptionsDialogPage
list of pages to add your custom options dialog page(s) to.
See Also