Click or drag to resize

PlugIn Methods

The PlugIn type exposes the following members.

Methods
  NameDescription
Protected methodAskUserForLicense
Public methodCommandSettings
Protected methodCreateCommands
Called right after plug-in is created and is responsible for creating all of the commands in a given plug-in. The base class implementation Constructs an instance of every publicly exported command class in your plug-in's assembly.
Public methodDisplayHelp
Called by Rhino if AddToHelpMenu is true and menu item associated with this plug-in is selected.
Protected methodDocumentPropertiesDialogPages
Override this function if you want to extend the document properties sections of the options dialog. This function is called whenever the user brings up the Options dialog.
Public methodStatic memberFind(Assembly)
Finds the plug-in instance that was loaded from a given assembly.
Public methodStatic memberFind(Guid)
Finds the plug-in instance that was loaded from a given plug-in Id.
Public methodStatic memberFlushSettingsSavedQueue
Public methodGetCommands
All of the commands associated with this plug-in.
Public methodStatic memberGetEnglishCommandNames
Gets names of all "non-test" commands for a given plug-in.
Public methodStatic memberGetInstalledPlugInFolders
Public methodStatic memberGetInstalledPlugInNames
Returns the names of all installed Rhino plug-ins.
Public methodStatic memberGetInstalledPlugInNames(PlugInType, Boolean, Boolean)
Gets a list of installed plug-in names. The list can be restricted by some filters.
Public methodStatic memberGetInstalledPlugInNames(PlugInType, Boolean, Boolean, Boolean)
Gets a list of installed plug-in names. The list can be restricted by some filters.
Public methodStatic memberGetInstalledPlugIns
Get a list of all registered plug-in's regardless of if they are loaded or not.
Public methodStatic memberGetInstalledPlugIns(Boolean)
Get a list of all registered plug-in's regardless of if they are loaded or not.
Protected methodGetLicense(LicenseBuildType, ValidateProductKeyDelegate, OnLeaseChangedDelegate)
Verifies that there is a valid product license for your plug-in, using the Rhino licensing system. If the plug-in is installed as a standalone node, the locally installed license will be validated. If the plug-in is installed as a network node, a loaner license will be requested by the system's assigned Zoo server. If the Zoo server finds and returns a license, then this license will be validated. If no license is found, then the user will be prompted to provide a license key, which will be validated.
Protected methodGetLicense(LicenseCapabilities, String, ValidateProductKeyDelegate, OnLeaseChangedDelegate)
Verifies that there is a valid product license for your plug-in, using the Rhino licensing system. If the plug-in is installed as a standalone node, the locally installed license will be validated. If the plug-in is installed as a network node, a loaner license will be requested by the system's assigned Zoo server. If the Zoo server finds and returns a license, then this license will be validated. If no license is found, then the user will be prompted to provide a license key, which will be validated.
Protected methodGetLicenseOwner
Get the customer name and organization used when entering the product license.
Public methodStatic memberGetLoadProtection
Get load protection state for a plug-in
Public methodStatic memberGetPlugInInfo
Returns detailed information about an installed Rhino plug-in.
Public methodGetPlugInObject
Public methodStatic memberGetPluginSettings
Public methodIcon
Returns the plug-in's icon in bitmap form.
Public methodStatic memberIdFromName
Gets the id of an installed plug-in giving the plug-in's name.
Public methodStatic memberIdFromPath
Gets the id of an installed plug-in giving the plug-in's file path.
Public methodIsTextureSupported
Returns true if this renderer can render the texture natively without needing it to be baked into a bitmap, false otherwise. By default, returns false for all textures.
Public methodStatic memberLoadComputeExtensionPlugins
Used by compute's startup code to load plug-ins that have registered custom endpoints
Public methodStatic memberLoadPlugIn(Guid)
Loads an installed plug-in.
Public methodStatic memberLoadPlugIn(String, Guid)
Attempt to load a plug-in at a path. Loaded plug-ins are remembered by Rhino between sessions, so this function can also be considered a plug-in installation routine
Public methodStatic memberLoadPlugIn(Guid, Boolean, Boolean)
Loads an installed plug-in.
Public methodStatic memberNameFromPath
Gets a plug-in name for an installed plug-in given the path to that plug-in.
Protected methodObjectPropertiesPages(ListObjectPropertiesPage) Obsolete.
Override this function is you want to extend the object properties dialog
Protected methodObjectPropertiesPages(ObjectPropertiesPageCollection)
Override this function is you want to extend the object properties dialog. This method will be called each time a new document is created for each instance of a object properties panel. On Windows there will be a single panel per document but on Mac there may be many properties panel per document.
Protected methodOnLoad
Is called when the plug-in is being loaded.
Protected methodOnShutdown
Protected methodOptionsDialogPages
Override this function if you want to extend the options dialog. This function is called whenever the user brings up the Options dialog.
Public methodStatic memberPathFromId
Gets the path to an installed plug-in given the id of that plug-in
Public methodStatic memberPathFromName
Gets the path to an installed plug-in given the name of that plug-in
Public methodStatic memberPlugInExists
Verifies that a Rhino plug-in is installed.
Public methodStatic memberRaiseOnPlugInSettingsSavedEvent
Raise any pending OnPlugInSettingsSaved events, the events are normally queued while a command is running and fired while Rhino is in an idle state. Calling this method will raise any pending changed events regardless of Rhino's current idle state or if a command is running.
Protected methodReadDocument
Called whenever a Rhino document is being loaded and plug-in user data was encountered written by a plug-in with this plug-in's GUID.
Protected methodRegisterCommand
Protected methodResetMessageBoxes
Protected methodReturnLicense
Returns, or releases, a product license that was obtained from the Rhino licensing system. Note, most plug-ins do not need to call this as the Rhino licensing system will return all licenses when Rhino shuts down.
Public methodStatic memberSavePluginSettings
Public methodSaveSettings
Write settings to disk which will raise a SettingsSaved event.
Protected methodSetLicenseCapabilities
Public methodStatic memberSetLoadProtection
Set load protection state for a certain plug-in
Protected methodShouldCallWriteDocument
Called whenever a Rhino is about to save a .3dm file. If you want to save plug-in document data when a model is saved in a version 5 .3dm file, then you must override this function to return true and you must override WriteDocument().
Protected methodWriteDocument
Called when Rhino is saving a .3dm file to allow the plug-in to save document user data.
Top
See Also