Click or drag to resize

PlugInGetInstalledPlugInNames Method (PlugInType, Boolean, Boolean)

Gets a list of installed plug-in names. The list can be restricted by some filters.

Namespace:  Rhino.PlugIns
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static string[] GetInstalledPlugInNames(
	PlugInType typeFilter,
	bool loaded,
	bool unloaded
)

Parameters

typeFilter
Type: Rhino.PlugInsPlugInType
The enumeration flags that determine which types of plug-ins are included.
loaded
Type: SystemBoolean
true if loaded plug-ins are returned.
unloaded
Type: SystemBoolean
true if unloaded plug-ins are returned.

Return Value

Type: String
An array of installed plug-in names. This can be empty, but not null.
See Also