Click or drag to resize

RenderPlugInRender Method

Called by Render and RenderPreview commands if this plug-in is set as the default render engine.

Namespace:  Rhino.PlugIns
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
protected abstract Result Render(
	RhinoDoc doc,
	RunMode mode,
	bool fastPreview
)

Parameters

doc
Type: RhinoRhinoDoc
A document.
mode
Type: Rhino.CommandsRunMode
A command running mode.
fastPreview
Type: SystemBoolean
If true, lower quality faster render expected.

Return Value

Type: Result
If true, then the renderer is required to construct a rapid preview and not the high-quality final result.
See Also